Notifications
Clear all

SLL certificate required

20 Posts
3 Users
0 Reactions
936 Views
Posts: 25
Topic starter
(@norcom41)
Eminent Member
Joined: 7 months ago

When I installed the plugin I read your documentation including …/getting-started/forum-page.  It starts “When you activate wpForo it creates (default board) and forum page with /community/ slug.  Forum home page can be found calling example.com/community/URL.  If you already have a page or post with ‘community’ slug” etc.  Furthermore “Forum page only contains [wpforo] shortcode”.

The answer to what I’m trying to figure out is there somewhere in the “docs.”  But as happens, the documentation was written by an engineer and I myself can only get a glimpse of what it means because I’m just a user.

Reply
Posts: 25
Topic starter
(@norcom41)
Eminent Member
Joined: 7 months ago

The web host told me the SSL cert was installed but “Not secure” appears anyway during the test.  However it tries though doesn’t find the program.  So I used FTP to try to locate it but the community folder is not shown by FTP.

The actual URL is listed as follows to show the detail.  The forum and topic slugs are there which are stored in the MySQL database. So it wants to navigate to a specific destination and not to just display a blank form.

Not secure:  http://biblebookletstore.com/community/jesus-saves/reb1-2adam_sin/

Forum - Page Not Found

Oops! The page you requested was not found!

You can go to Forum Home page or Search here

Also I just ran the version update for wpforo to get the latest changes but it doesn’t load any community files.  Do I have to reinstall it from the beginning to get files loaded that were mistakenly omitted the first time?

Reply
adisaputro
Posts: 127
(@adisaputro)
Estimable Member
Joined: 6 years ago

The SSL installed on your website is already valid. The issue with your website is that you haven't properly set up the HTTP to HTTPS redirect. Just add this code to your wp-config.php file:

if (isset($_SERVER['HTTP_X_FORWARDED_PROTO']) && $_SERVER['HTTP_X_FORWARDED_PROTO'] === 'http') {
$_SERVER['HTTPS'] = 'on';
}

Place that code before the ?> tag. Good luck, give it a try and hopefully it will work.

Reply
Robert
Posts: 10543
Admin
(@robert)
Support Team
Joined: 8 years ago

@norcom41,

1. Go to Dashboard > Settings > General admin page and make sure website URLs are set with https:// protocol and save them again.

2. Go to Dashboard > Settings > Permalinks, make sure the permalink is set /%postname%/ and save it.

3. Go to wpForo > Boards admin page, edit the board and save it.

4. Go to wpForo > Overview admin page and click [Delete all Caches] button.

5. Then do either the code provided by @adisaputro or install and configure this plugin https://wordpress.org/plugins/really-simple-ssl/

Reply
Posts: 25
Topic starter
(@norcom41)
Eminent Member
Joined: 7 months ago

I added the stmt to wp-config and ran the test again.  Here is some of the display.  Got the same error so will try the other suggestion (if I can figure it out).

Bible Study Booklets Forum

 Unread Posts  |  Forums   |  Topics 

Foundational

Jesus Saves

Saved from Sin

Recent Topics   

By study4U2
3 weeks ago

Foundational

Jesus Saves

reb1-2Adam_sin

reb1-2Adam_sin

JESUS SAVES

 Last Post by study4U2 3 weeks ago

 Topic starter 09/01/2024 6:38 pm   

Saved from sin of Adam

Please Login or Register to reply to this topic.

Forum - Page Not Found

Reply
Page 2 / 4