Notifications
Clear all

Simple:Press to wpForo Problem

5 Posts
2 Users
0 Likes
2,798 Views
0
Topic starter

Hi I've been running a simple:press forum on my WP site and decided that wpForo was the way to go.

Installed wpforo, ran the migration and it worked fine, all forums/posts etc imported. I checked the wpForo dashboard and can see wpForo has 10.7K posts and everything looks fine structural wise. However when I try to view the wpForo forum I get the following error

Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0

If I try to view the old simple:press forum I get the following error

Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0

At this point I panicked thinking I had corrupted the old simple:press forum I deactivated the wpForo installation and the simple:press forum loaded OK. Phew!

So the question is why does the wpForo forum fail to load despite appearing to migrate OK. Why does it stop the simple:press forum form working. Is there a way around this, do I have to deactivate the simple:press installation to allow wpForo to work. I'm loathed to do that in case it causes trouble.

Not technical enough to know what's going on.

 

4 Answers
0

This is a caching or optimizing plugin problem. Please delete all caches , then deactivate all plugins related to cache and website optimization (Autoptimizer). Then deactivate Simple:Press and activate wpForo.

I think Cache or optimizer plugins have not rendered imported data yet and they stop working when new plugin load new content. Also this maybe Simple:Press conflict. So please do the steps above, also try to deactivate other plugins to find the conflict point.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

cmw14 cmw14 Topic starter 13/11/2017 11:06 am

Thanks, it was a simple:press conflict

I deactivated simple:press and wpforo sprang to life. 

Really pleased and congrats on such a superb forum I'm a total convert so much better than Simplepress.

Also the excellent migration tool, everything had ported over correctly including attachments. Wow! if only everyone could do so good.

Only problem I'm left with is number of post not showing on the users post profile. It shows their avatar, reputation level and badge etc just nothing about join date or number of posts, but I notice that's the same here

<------

Still that's the only thing and I'm not going to lose sleep over it.

Cheers

0

Thank you cmw14,

Please try to delete User cache, navigate to Dashboard > Forums > Dashboard admin page, click on [Update Users Statistic] button then [Delete Users Cache] button.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

0
Topic starter

Did that but the side post profile does not show post count or join date. If you click on the main users profile it does dhow all the in fo and more.

I thought it might be an option I missed but does not seem so.

Just in case our wires are crossed I've attached image that shows a post side profile with post count and join date. This is what I wish to see on my forum. As I mentioned above looking at the ones on this forum, they are also not displayed.

 

0

It seems you're not familiar with wpForo Forum layouts. You use the Simplified Layout, the info you want exists in Extended Layout. Also there is Q&A layout. Just change the top (blue) category layout and all Forums under this category will inherit the selected layout.

Please read the doc about wpForo Forum Layouts:

https://wpforo.com/docs/root/categories-and-forums/forum-layouts/

After changing layouts, please navigate to Dashboard > Forums > Dashboard and click on [Delete all caches] button.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

Answer