Notifications
Clear all

How do I put a subforum inside a page?

14 Posts
2 Users
1 Likes
4,649 Views
theo
Posts: 31
 theo
Topic starter
(@theo)
Eminent Member
Joined: 4 years ago

I don't want to place the entire forum, just one subforum. How do I put the forum on the page?

Topic Tags
13 Replies
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi @theo,

You can use this shortcode: [wpforo item="forum" id="2"] 

Just change 2 to the subforum ID of topics you want to display. You can find subforum IDs in Dashboard > Forums > Forums admin page. 

Reply
theo
Posts: 31
 theo
Topic starter
(@theo)
Eminent Member
Joined: 4 years ago

Thanks, this did the trick on my regular pages, but on my custom content view page this shortcode produces the forum statistics as text, but no buttons or border styling or actual topic. Is this a known issue?

Upon checking the page source, here is what I have:

Displays only text and missing forum information. (on content template) using [wpforo item="forum" id="5"]
------------------------------------------------------------


<div id="wpforo-wrap" class="wpf-dark">

<div class="wpforo-subtop">

<div class="wpf-breadcrumb">
<a href="#" class="wpf-root active">Forums</a>
<a href="#" class="wpf-end">&nbsp;</a>
</div>

<div class="wpf-clear"></div>
</div>
<div class="wpforo-main wpft-">
<div class="wpforo-content "style="width:100%">

Displays perfectly. on a page with [wpforo item="forum" id="5"]
---------------------------------------------------------------

<div id="wpforo-wrap" class="wpf-dark">

<div class="wpforo-subtop">

<div class="wpf-breadcrumb">
<a href="http://localhost/wordpress2018/community/" class="wpf-root" title="Forums"><i class="fas fa-home"></i></a>

<a href="http://localhost/wordpress2018/community/questions/" title="Questions">Questions</a>
<a href="#" class="active" title="Airplanes Q&amp;A">Airplanes Q&A</a>

<a href="#" class="wpf-end">&nbsp;</a>
</div>

<div class="wpf-clear"></div>
</div>
<div class="wpforo-main wpft-topic">
<div class="wpforo-content "style="width:100%">





Reply
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi @theo,

Please delete all caches, press Ctrl+F5 twice. if it doesn't fix, disable all caching/optimizing/minifying/compressing plugins, delete all caches and test it again.

Reply
theo
Posts: 31
 theo
Topic starter
(@theo)
Eminent Member
Joined: 4 years ago

@sofy I have done all that, and still this is what is displayed.

Reply
Page 1 / 3
Share: