Notifications
Clear all

Twitter and LinkedIn login to wpForo

10 Posts
5 Users
4 Likes
1,193 Views
StocksForum
Posts: 135
Topic starter
(@stocksforum)
Estimable Member
Joined: 4 years ago

I see Facebook comes in the wpForo API settings, but what's the best way to integrate Twitter and LinkedIn logins? (if possible)

I was looking at this plugin:
https://nextendweb.com/social-login/

Am open to suggestions and feedback with what will work best.

Lots of people in my industry only use either Twitter or LinkedIn.
Having them as login/register options would make things much easier.

Topic Tags
9 Replies
4 Replies
Mark Ransome
(@markransome)
Joined: 3 years ago

Eminent Member
Posts: 20
Posted by: StocksForum

I see Facebook comes in the wpForo API settings, but what's the best way to integrate Twitter and LinkedIn logins? (if possible)

I was looking at this plugin:
https://nextendweb.com/social-login/

Am open to suggestions and feedback with what will work best.

Lots of people in my industry only use either Twitter or LinkedIn.
Having them as login/register options would make things much easier.

Did you ever try this plugin?

Mark

Reply
StocksForum
(@stocksforum)
Joined: 4 years ago

Estimable Member
Posts: 135

Yeah I did, it works. But I don't use it now as some people may have old emails they used to register with social media. By getting their email the normal way I can confirm it is their regular email.

Reply
Mark Ransome
(@markransome)
Joined: 3 years ago

Eminent Member
Posts: 20

So you don't even use the built-in Facebook Register/Login then?

I can see what you mean about the emails, I have never thought about that before!

Mark

Reply
StocksForum
(@stocksforum)
Joined: 4 years ago

Estimable Member
Posts: 135
Robert
Posts: 9327
Admin
(@robert)
Support Team
Joined: 6 years ago

I think you can use any of Social Login plugin, they'll add according login buttons on wpForo Login / Register forums: https://wordpress.org/plugins/search/social+login/

Reply
4 Replies
jovial_cynic
(@jovial_cynic)
Joined: 3 years ago

New Member
Posts: 2

@robert

I've installed a social plugin (Nextend), and it seems to be working swimmingly with the regular WP site, as there's a nice "Continue with Facebook" and "Continue with Twitter" button across the login page. However, on the WpForo login, the buttons are barely visible. 

I've made no customizations to the theme, and I'm not sure how to fix this.

I've attached an image showing both the good version and the bad version of the the buttons. 

Thanks!

Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9327

@jovial_cynic

Please leave a URL to that page allowing us debug CSS issues.

Reply
jovial_cynic
(@jovial_cynic)
Joined: 3 years ago

New Member
Posts: 2
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@jovial_cynic

It is a CSS conflict. To solve it, just navigate to Dashboard > Forums > Settings > Styles admin page, put the following CSS code in "Custom CSS Code" textarea, save it, delete all caches and check again.

.nsl-container-buttons a span {
display: inline-table !important;
}
div.nsl-container .nsl-button-default span.nsl-button-label-container {
margin: 0 24px 0 12px !important;
padding: 10px 0 !important;
font-size: 16px !important;
line-height: 20px !important;
flex: 1 1 auto !important;
}

.nsl-container-buttons {
display: flex !important;
align-items: center !important;
}

div.nsl-container .nsl-button-svg-container {
flex: 0 0 auto !important;
padding: 8px !important;
display: flex !important;
}
div.nsl-container-block .nsl-container-buttons a {
flex: 1 1 auto !important;
display: block !important;
margin: 5px 0 !important;
max-width: 280px !important;
width: 100% !important;
}
div.nsl-container .nsl-button-default {
color: #fff !important;
display: flex !important;
}

Please don't forget to press Ctrl+F5 (twice) on the forum frontend before checking to reload the updated CSS file.     

Reply
Share: