Avatar file path in...
 
Notifications
Clear all

Avatar file path incorrect

4 Posts
2 Users
0 Likes
141 Views
Posts: 3
Topic starter
(@johno)
Active Member
Joined: 3 months ago

Hi

The avatar path appears to have been changed. I have tried deleting forum cache and site cache, and flushing permalinks.

using inspector, the avatar path in wpforo is looking for /wp-content/uploads/wpforo/avatar lazyloads/john_2.jpeg but that's a 404.

the server path is /wp-content/uploads/wpforo/avatars/john_2.jpeg

There's no "avatar lazyloads" folder. 

 

wpForo Version
2.1.1
WordPress Version
6.1.1
3 Replies
Posts: 3
Topic starter
(@johno)
Active Member
Joined: 3 months ago

I had Siteground optimiser activated during the initial install of wpforo and continuously since then. There were no issues.

There was a recent update of wpforo, it is since then the issue occurred.

I have just now disabled lazy loading of imaged in Siteground optimiser, and the forum avatar issues resolved.

I've done no further troubleshooting, but it appears, superficially, there's a compatibility issue with wpforo and the Siteground optimiser plugin.

 

 

Reply
Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago

@johno,

Please make sure the main page of your forum and the forum profile path are excluded from your cache plugin. Here is the instruction, if your forum path is not /community/ then change the first line to your forum path:

SiteGround Optimizer plugin

  1. Please navigate in Dashboard to SG Optimizer > Caching admin page
  2. Scroll to Exclude URLs from Caching section and click the "pencil" button, enable it, and click the button again
  3. Insert the URL path(s) of your forum page(s) with wildcard [*] in the pop-up filed:
    /community/*
    /participant/*
    /sign-up/*
    /sign-in/*
    /change-password/*
  4. Save it and delete all caches.
Reply
1 Reply
(@johno)
Joined: 3 months ago

Active Member
Posts: 3

@robert Hi

I did that on the original set up three months ago.

Thanks.

Reply