Notifications
Clear all

wpForo 1.x.x [Closed] Activity Stream not working

12 Posts
3 Users
0 Reactions
1,029 Views
Posts: 13
Topic starter
(@drumlinking)
Active Member
Joined: 4 years ago

When I click user activity stream, it does not work. I get 404 page. Any idea where this setting could be fixed? I checked Forums> Usergroups and 'Front - Can view member activity' is checked for each role. Thanks.

11 Replies
Sofy
Posts: 4493
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi @drumlinking,

Could you please leave your forum URL to allow us to check the issue? 

Posts: 13
Topic starter
(@drumlinking)
Active Member
Joined: 4 years ago

I can send you login details because site access requires membership.

Robert
Posts: 10527
Admin
(@robert)
Support Team
Joined: 8 years ago
Posted by: @drumlinking

When I click user activity stream, it does not work.

Please let me know what activity stream you mean? Are you sure it's the wpForo part?

If so, please take a screenshot of Forums > Settings > General Tab and attach it here I want to see forum page URL settings.

Posts: 13
Topic starter
(@drumlinking)
Active Member
Joined: 4 years ago

Attached is pic of Activity Stream button that I mention. It goes to 404 page.

7 Replies
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10527

@drumlinking,

Ok thank you. But I asked a screenshot of the Forums > Settings > General Tab .

And I don't understand what you show on the screenshot. Can you add some points in that screenshot?

(@drumlinking)
Joined: 4 years ago

Active Member
Posts: 13
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10527

@drumlinking,

I need the values below the screenshot. The values of the "Forum Page Slugs" option.

1. As far as I see your profile URL are affected by other plugins. Do you have any other profile plugin installed?

2. Can you change the value of "activity" page to something like "activity-stream":

 

3. And I need an example of that Activity Stream page URL.

(@drumlinking)
Joined: 4 years ago

Active Member
Posts: 13
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10527

@drumlinking,

Ok, thank you, then follow to my post above.

(@drumlinking)
Joined: 4 years ago

Active Member
Posts: 13

@robert The activity goes to https://letslearnirish.com/members/MEMBER/community
404, but works when 'community' is replaced with 'activity' (as set up on site). How to change this link?
Yes, site using pmpro and Buddypress plugins.

The forum base URL is /forum
The Forum Page Slugs (URL Paths) > Activity = Activity

Member Activity button goes to URL/members/graeme/community

instead of URL/members/graeme/activity

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10527

@drumlinking,

All is correct.

1. If you have bbPress plugin activated, please deactivate it.

2. This URL is the Forum Activity URL in BuddyPress Profile Page. So please navigate to Dashboard > Forums > Settings >  Features admin page and enable the "BuddyPress Profile Forum Tab Integration" option.

The Forum Tab should look like this in the BuddyPress user profile page: