Notifications
Clear all

wpForo 1.x.x [Solved] Custom Avatars Broken Images

8 Posts
3 Users
3 Likes
914 Views
Cantiara
Posts: 4
Topic starter
(@cantiara)
New Member
Joined: 2 years ago

Hello,

I am using WPForo plugin for my website's community forum.

Just earlier, I was running a speed test on my website, and unfortunately, it was showing poor performance. Consequently, I took the action to optimize it through SG Optimizer and CloudFlare. But after doing that, all the custom avatars in the forum appear to be broken (see screenshot).

I have asked the hosting company to clear all the cache on their side as well as CloudFlare. I have also reset my permalinks just in case. But it didn't help at all. Even after clearing my own browser cache, I still see the broken custom avatar images.

I'd like to know if you are having issues with caching software such as CloudFlare and SG optimizer. And could you provide me with additional information on what needs to be done in order for these avatars to come back?

Thank you in advance. 

7 Replies
Alvina
Posts: 1872
Moderator
(@alvina)
Member
Joined: 3 years ago

Hi @cantiara,

I'd like to know if you are having issues with caching software such as CloudFlare and SG optimizer. And could you provide me with additional information on what needs to be done in order for these avatars to come back?

1. For the SG optimizer cache plugin:

Please exclude the wpForo Forum page from your cache plugin!

Almost all cache plugins should have an option to exclude pages from the caching process. You should exclude your forum home page from your cache plugin. This is very important.

More info here: https://wpforo.com/community/faq/wpforo-and-cache-plugins/

2. For the Cloudflare:

Please try to exclude the base forum path: /community* from Cloudflare's caching:

More info in this article:

https://support.cloudflare.com/hc/en-us/articles/200172316-How-do-I-exclude-a-specific-URL-from-Cloudflare-s-caching-

Also please navigate to Dashboard > Forums > Dashboard admin page, one by one click on the [Delete User Cache] and [Delete All Caches] buttons.

Finally, go to the forum front page do CTRL+F5(twice), and check again.

Reply
Cantiara
Posts: 4
Topic starter
(@cantiara)
New Member
Joined: 2 years ago

Hi @alvina

Thank you for your timely response.

I've excluded my WP Forum page from SG Optimizer (see attachment).
And Cloudflare Full Page Caching is currently disabled. 

I deleted user cache and all cache from the forum dashboard, hard refreshed the forum page twice, the avatar is still shown as broken.

Could you please provide me with further assistance regarding this issue?

 

Thank you.

 

Reply
5 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@cantiara,

I think this is the HTTPS protocol issue. Make sure your website uses a valid SSL certificate. Then install WP Force SSL plugin and enable "Force SSL" option:

 

If this doesn't help, please leave your forum URL allowing us to check the avatar sources.

Reply
Cantiara
(@cantiara)
Joined: 2 years ago

New Member
Posts: 4

Hi @robert,

Thank you for your response. 

I did as you suggested, but the issue persists.

My forum URL is https://www.thewriterscircus.com/community

I hope you'd be able to pinpoint the problem. 

Thank you in advance.

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@cantiara,

This problem comes from your optimizer/cache plugin, it has "image lazy load" option which works incorrectly, it's probably the SG Optimizer Plugin. It adds lazyload to avatar URLs and breaks source URLs. Please find that plugin and disable this option. Then delete all caches.

Also, find an option in this plugin to exclude forum pages, here is instruction: https://wpforo.com/community/faq/wpforo-and-cache-plugins/

I see it's not excluded yet.

 

 

Reply
Cantiara
(@cantiara)
Joined: 2 years ago

New Member
Posts: 4

@robert

You're right! It had to do with the lazy image option. I disabled it and the images are now showing properly again.  

I've excluded my forum page from the SG Optimizer plugin (see screenshot). Please let me know if I did it correctly.

Thank you so much. I really appreciate your and Alvina's assistance. Will leave a review later. 

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

Thank you, @cantiara,

Please append the wildcard sign "*" to exclude the entire forum section, it should be:

......./community/*
Reply