Notifications
Clear all

wpForo 1.x.x [Closed] Double Log in / Members

28 Posts
3 Users
1 Reactions
3,089 Views
Posts: 36
Topic starter
(@2ndlifeclub-com)
Eminent Member
Joined: 5 years ago

Hello All -

First off a big thank you to everyone who has helped me in the past!  I just set up my forum, not a technical person so I appreciate the patience in responding.  I have a double issue, on my site to log in I have 2 locations, can anyone tell me how to deactivate the top one so only the one on the bar works?

 

27 Replies
3 Replies
(@2ndlifeclub-com)
Joined: 5 years ago

Eminent Member
Posts: 36
Posted by: 2ndLifeClub.com

Hello All -

First off a big thank you to everyone who has helped me in the past!  I just set up my forum, not a technical person so I appreciate the patience in responding.  I have a double issue, on my site to log in I have 2 locations, can anyone tell me how to deactivate the top one so only the one on the bar works?

I also have this...when people are registering, it is going under my Wordpress under users (see attached), they are subscribers...is this currect?

 

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4412

Hi @2ndlifeclub-com,

Please check the following options:

  • Navigate to Dashboard > Forums > Settings > Features admin page, make sure the HTML Cache is disabled. 
  • Navigate to Dashboard > Appearance > Menu admin page, select the "wpForo Navigation (wpForo Menu)" make sure the login URL is correct, see the screenshot below. 
  • Deactivate all cache plugins and check again.

The login menu item specific shortcode-URL is /%wpforo-login%/

More info here: https://wpforo.com/docs/root/getting-started/forum-menu/

(@2ndlifeclub-com)
Joined: 5 years ago

Eminent Member
Posts: 36

Thank you for your reply.

  • I checked and my HTML Cache was disabled. 
  • For the login, please see my screenshot as this was the only way I could get people to register.
  • I have no cache plugins so that was easy

Was this to stop the double log in or to separate my members from users?  I'm asking because I'm a little confused about it all.

Thank you in advance!

Posts: 36
Topic starter
(@2ndlifeclub-com)
Eminent Member
Joined: 5 years ago

Does everyone else have 2 logins?  I just deleted a "user" from wordpress that was a "member" on the forum and it deleted them from the member list so I'd like to resolve this 

4 Replies
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4412

ok @2ndlifeclub-com,

The URL is not correct, please remove it and add this one: /%wpforo-login%/

 

(@2ndlifeclub-com)
Joined: 5 years ago

Eminent Member
Posts: 36

Thank you as now it is working...however it still puts the new user as a user in Wordpress and a member in the forum, is there a setting so new subscribers do not go to my wordpress users?

Also when people are registering its showing that it's coming from Wordpress and the subject line is my website (see sample)

(@2ndlifeclub-com)
Joined: 5 years ago

Eminent Member
Posts: 36

Actually it still shows a double log in, the wordpress one in the upper right hand corner and then the membership one 😮 

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4412

ok @2ndlifeclub-com,

Please send the admin login details to info[at]gvectors.com email address to allow us to check it. 

Sofy
Posts: 4412
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi @2ndlifeclub-com,

The first issue with the double login menu item is already solved, we've just changed the shortcode in the login URL field. Please watch the video:

https://www.screencast.com/t/72bBo63w47

I'm also having issues that when people sign up it shows under members and wordpress under users (I'd like to omit the users under wordpress)

wpForo and WordPress users are the same. If a user is registered on WordPress it's already registered in wpForo automatically. When user login it's already logged in for wpForo too.

Finally, I have something clicked for anyone who posts they need to be approved, I don't mind approving the first 5 posts but I do not want to worry about approving every post, can you assist me with that as well?

In this case, you should check the "Can pass moderation" CAN from Dashboard > Forums >Usergroup admin page. Just edit the current Usergroup and check this permission. I see you've enabled it for Registered Usergroup, thus all posts made by this Usergroup become unapproved. 

12 Replies
(@2ndlifeclub-com)
Joined: 5 years ago

Eminent Member
Posts: 36

now when I go to the "community" page it brings me straight to logging in and I can not view the forums so I only get the login page

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4412

Check it again, please.

You'd enabled the "Replace Login Page URL to Forum Login Page URL" option in Dashboard >  Forums > Settings > Features Tab. I've already unchecked this option. Now everything should work fine. 

(@2ndlifeclub-com)
Joined: 5 years ago

Eminent Member
Posts: 36

What do I need to enable from the usergroup to allow registered people to post without it being modified? 

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4412

I've already answered this question here:

https://wpforo.com/community/how-to-and-troubleshooting-2/double-log-in-members/#post-25461

Please read more attentively. The answer is: 

In this case, you should check the "Can pass moderation" CAN from Dashboard > Forums >Usergroup admin page. Just edit the current Usergroup and check this permission. I see you've enabled it for Registered Usergroup, thus all posts made by this Usergroup become unapproved. 

(@2ndlifeclub-com)
Joined: 5 years ago

Eminent Member
Posts: 36

Have you tested the login on my page?  It now reverts back to my website home page instead of your login

(@2ndlifeclub-com)
Joined: 5 years ago

Eminent Member
Posts: 36

Also Sofy - 

While I do appreciate your response to the moderation, you fail to understand that I am not a technical person and do NOT know what you are speaking of.  The member Chris, was kind enough to help me with screen shots to understand and allow me to get to where I am.  I provided a screenshot, mine is different than yours and unfortunately, I don't understand what you are speaking of...only because this is foreign to me and what you take for granted in understanding in a program leaves people like me only frustrated

(@2ndlifeclub-com)
Joined: 5 years ago

Eminent Member
Posts: 36
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4412

ok @2ndlifeclub-com,

Please let me know if the admin accesses are available now. If the accesses are not available please send the new one. 

About the moderation, please read this support topic: 

https://wpforo.com/community/how-to-and-troubleshooting-2/how-to-set-the-forum-so-usergroup-does-not-need-moderation/

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4412

Hi @2ndlifeclub-com,

The problem with the login URL is solved. You'd added an additional slash in  Custom Authorization URLs" option thus it stopped work. We've already removed it, now everything is working fine. Please watch the video: 

https://www.screencast.com/t/ETxO2oa5cILZ

Also please let us know about moderation. Is there everything clean in the support topic I've provided? 

(@2ndlifeclub-com)
Joined: 5 years ago

Eminent Member
Posts: 36

Good morning and thank you!  I can not watch the video right now as I am at work but I will check it out later.  

 

I still have the double sign in (see attached), if someone uses this login at the top it will log them into wordpress, is there a way to get rid of it?

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4412

The login button located at the top of the webpage doesn't belong to wpForo. It comes from your theme or other plugins. The easy solution I can provide here is a CSS code that allows hiding this part. Please navigate to Dashboard > Forums > Settings > Styles admin page, add the following code in "Custom CSS code " textarea, save it, delete all caches and check again. 

.mk-header-toolbar { 
display: none;
}
(@2ndlifeclub-com)
Joined: 5 years ago

Eminent Member
Posts: 36

Thank you!  I've added the coding but the login is still there.

Posts: 36
Topic starter
(@2ndlifeclub-com)
Eminent Member
Joined: 5 years ago

Also when members register from the forum page, they are emailed with a link (I did not change any coding) when they click on the link it brings them to my wordpress dashboard so I am getting emails about the confusion.  Where can I find how to fix this?  

Posts: 36
Topic starter
(@2ndlifeclub-com)
Eminent Member
Joined: 5 years ago

and when guests login, instead of being on the home page for the forums it brings them to the members page

Page 1 / 2