Notifications
Clear all

[Solved] Email links not taking users to last post

9 Posts
3 Users
2 Likes
390 Views
marsm
Posts: 110
Topic starter
(@marsm)
Estimable Member
Joined: 3 years ago

Since the upgrade, I’ve got some users saying that when they click links in email notifications they are taken to the first page of the topic, not to the last read post. Any suggestions?

8 Replies
Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @marsm,

Navigate to Dashboard > wpForo > Settings > Action Logging & Views Settings and enable Topic Links - Jump to First Unread Post.

marsm
Posts: 110
Topic starter
(@marsm)
Estimable Member
Joined: 3 years ago

Thanks Chris. I can confirm that I had already had that enabled, but it's still not working. I've just tested on my account from my mobile phone and it takes me to the first page. 

1 Reply
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@marsm,

please provide forum URL.

marsm
Posts: 110
Topic starter
(@marsm)
Estimable Member
Joined: 3 years ago
4 Replies
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@marsm,

Checked in your website with wpForoSupport account works correctly. After first time checking the topic and going to the last post, I have opened the same topic again and it jumped the last post.

marsm
(@marsm)
Joined: 3 years ago

Estimable Member
Posts: 110

@chris, whenever I click a link from an email notification it takes me to the first page. When on the site, when clicking on the links they go to the latest post, I agree. It's the links from emails that don't.

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10475

@marsm,

Try to change [topic_url] and [topic_link] email shortcodes to [post_link]. The email templates can be found in wpForo > Settings > Subscriptions & Mentioning tab

marsm
(@marsm)
Joined: 3 years ago

Estimable Member
Posts: 110

@Robert that worked perfectly. Thank you.