Notifications
Clear all

wpForo 1.x.x [Solved] Font Awesome icons not showing

5 Posts
3 Users
0 Likes
1,056 Views
gokberktalu
Posts: 7
Topic starter
(@gokberktalu)
Active Member
Joined: 2 years ago

Hi,

 

I use WpRocket and AssetCleanUp Pro. I excluded the entire page but it seems my icons (all of them) are not showing.

Please check the page:

https://www.turkishaholic.com/community/

Could you tell me what I need to do? Or someone help me fix it please?

 

Thanks.

4 Replies
gokberktalu
Posts: 7
Topic starter
(@gokberktalu)
Active Member
Joined: 2 years ago

I can fix the issue when I install FontAwesome's plugin, but I shouldn't need that. There should be an easier fix that doesn't rely on another plugin, right?

Reply
1 Reply
Alvina
Moderator
(@alvina)
Joined: 3 years ago

Member
Posts: 1872

@gokberktalu,

As we can see the issue is fixed. Can you please confirm it?

Reply
gokberktalu
Posts: 7
Topic starter
(@gokberktalu)
Active Member
Joined: 2 years ago

Actually I just installed the FontAwesome plugin, I'll disable it now so please check again.

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@gokberktalu,

Your problem comes from the CDN. The font-awesome CSS file loads Font-Awesome font files with relative paths and when they are loaded from CDN they are being blocked by browsers with "Cross-Origin Request Blocked" message:

 

Here is explained your problem: https://stackoverflow.com/a/49720387/357218

The solution can be adding a new CDN rule mentioned in the answer above, or just adding .htaccess rule: https://stackoverflow.com/questions/26125030/font-awesome-icons-not-showing-in-chrome-a-maxcdn-related-cross-origin-resource#26521650

Don't forget delete all caches and purge CDN after any change. Also, try other browsers and press Ctrl+F5 to reset browser cache.

 

If you still have the same issue, I recommend disable wpForo Font-Awesome Lib in Dashboard > Forums > Settings > Features Tab. Then install your font-awesome plugin.

Reply