Deleting a post hid...
 
Notifications
Clear all

[Solved] Deleting a post hides the topic from the forum.

32 Posts
3 Users
6 Reactions
2,366 Views
Posts: 27
Topic starter
(@surlofia)
Eminent Member
Joined: 2 years ago

First, could you see screenshots "WP Fastest Cache Exclude Setting of Cocoon.png".

As you can see, we alrready exclude the forum from our cache plugin.
https://wpforo.com/community/faq/wpforo-and-cache-plugins/

Deleting a post (or deleting a user of an approved post) hides the topic from the top of the forum.

It seems to be restored when I write to the hidden topic with administrator privileges.

I also tried deleting Cache from the forum dashboard, but no luck…

Apparently, it is not possible to delete the most recent post by the user….

I will try to block spam users without deleting them.

However, when I tried it today, the same thing happened with “delete spam posts” -> “block user”…

=====

However, we don’t think this setting has anything to do with the problem, because we disabled the plugin this time.

We don’t remember from which version of wpForo the problem occurred.
However, we are sure that it is v2.0.0 or later.

We suspect that the conditions of the bug are as follows

[condition #1]
Deleting a post that has been "unapproved" ("waiting for approval") will cause the topic to disappear from the top of the forum.
(We have created a similar environment and verified that the problem is reproduced here.)

Or

[condition #2]
Deleting a user who holds a post that has been "unapproved" ("awaiting approval") will cause the topic to disappear from the top of the forum.
(This is only speculation and we have not been able to reproduce the issue.)

=========

If there are spam submissions that have been "unapproved" and are "awaiting approval" (= under [condition #2]), the following steps may be necessary.

Step 1
Delete all spam submissions once written by pressing "Approve".
Step 2
Then delete the user.

In the previous version, it was OK to just delete the user, but to avoid the problem, the following procedure is necessary, which may be quite troublesome....

1. press "Approve
2. Delete the spam postings
3. Check if the spam user has any "waiting for approval" posts
4. Delete the user

Thank you for reading our long article.

 

31 Replies
Robert
Posts: 10545
Admin
(@robert)
Support Team
Joined: 8 years ago

@surlofia,

Please fully disable the cache plugin, deactivate it and test the issue again. We need to make sure this is not the cache plugin issue. Excluding the forum page may not be enough in some cases, so we need a radical way to test it.

5 Replies
(@surlofia)
Joined: 2 years ago

Eminent Member
Posts: 27

@robert,

We will check.
Could you please give me some time?
We will report back to you with the results.

By the way, could you tell us about the time difference where your company is located?

We are in GMT+9, Japan.

(@surlofia)
Joined: 2 years ago

Eminent Member
Posts: 27

@robert,

Last time, the cache plugin was verified with it disabled.

Does the verification at your company reproduce this?

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10545

Please, just disable the cache plugin, before disabling purge all kind of caches. Keep it disabled for a few hours and check the website.

My timezone: https://wpforo.com/participant/robert/

(@surlofia)
Joined: 2 years ago

Eminent Member
Posts: 27

@robert,

Italy!

8hours time difference.

> Keep it disabled for a few hours and check the website.

Let us try.

Thanks.

 

(@surlofia)
Joined: 2 years ago

Eminent Member
Posts: 27

@robert,

This is a test in a local environment.
This is not a server environment.

Note:

Only wpForo is used as a plugin.
No other plugins were used.
(Of course, no cache plug-ins were used.)

Please see our steps.gif

Posts: 27
Topic starter
(@surlofia)
Eminent Member
Joined: 2 years ago

@robert 

 

The above GIF video shows the sequence of steps, but I will explain the procedure in a nutshell.

(1) In the "Main Category" > "Main Forum" area, you will find the following four topics.

Topic 02
Topic 03
Topic 01
Idle Talk

(2) Open "Topic 02" above.

Then, you will find the following entry.

Edit Test 00001
Edit Test 00002
Edit Test 00003
Edit Test 00004

(3) Unapprove Edit Test 00004 and then Delete it.

Then, the following will remain

Edit Test 00001
Edit Test 00002
Edit Test 00003

Posts: 27
Topic starter
(@surlofia)
Eminent Member
Joined: 2 years ago

@robert

 

(4) After that, go to the "Main Forum" directly above.

Then, the following topics are displayed.

Topic 02
Topic 03
Topic 01
Idle Talk

 

Please see file. (4.jpg)

 

 

Posts: 27
Topic starter
(@surlofia)
Eminent Member
Joined: 2 years ago

@robert

(5) Go back to the forum home page.
You will see that "Topic 02" is not displayed.

Please see 5.jpg

Page 1 / 4