Notifications
Clear all

[Solved] All wpForo pages redirect to home page

19 Posts
6 Users
1 Likes
457 Views
Posts: 9
Topic starter
(@aamirpsy)
Active Member
Joined: 4 months ago

Hi, after updating the latest version of wpForo, all the links (post, topics) etc are not working. They redirect back to the home page. Any idea how to solve this?

wpForo Version
2.1.8
WordPress Version
6.2.2
18 Replies
Posts: 9
Topic starter
(@aamirpsy)
Active Member
Joined: 4 months ago

@robert anyone can help? My website useless if this problem maintain. 

Posts: 9
Topic starter
(@aamirpsy)
Active Member
Joined: 4 months ago

I roll back to previous version now and problem solved. Kindly update new verson soon with this problem solution. 

1 Reply
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 3653

Hi @aamirpsy,

Sorry for the late response, how can we check your website with the 2.1.8 version, and also, please note that you are using wpForo Classic Theme, which has bugs, we recommend using 2022 theme.

Posts: 10
(@aalaw)
Active Member
Joined: 1 year ago

After 2.1.8 update, I have the same problem.
Of course, with 2022 theme.
All posts redirected to front page.

This seems to be an issue when using 'Turn WordPress to this forum board'.
Adding 'community' to the url opens the post. I'm hoping for an update to fix the bug soon.

12 Replies
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 3653

@aalaw,

what I see now is that all the links are working.

About the option to set wpForo on the homepage.

You have just used "Turn WordPress to this forum board" button, or did other changes as well?

(@aamirpsy)
Joined: 4 months ago

Active Member
Posts: 9

@chris, I just update again but result same. you can check my link given above. Hope you share solution soon.

(Note: After 5 hours, I will roll back to previous version. Time count from this reply)

Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 3653

@aamirpsy,

clone your website and provide admin access to it, send the credentials to info[at]gvectors.com, mention this topic in the email and let me know here that the email is sent.

Write wpForo Credentials in the email Subject.

(@aamirpsy)
Joined: 4 months ago

Active Member
Posts: 9

@chris email is sent. Kindly check.

Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 3653

@aamirpsy,

Navigate to Dashboard > Rank Math > General Settings, Disable Redirect Attachments option.

(@aamirpsy)
Joined: 4 months ago

Active Member
Posts: 9

@chris Thank you for your assistance, Chris. I appreciate your prompt and helpful response. I would like to know what I should do next to complete the process. Is there anything else that I need to do on my end? Is my forum working fine now or do I need to adjust any other settings? Please let me know if you have any further instructions or suggestions for me.

Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 3653

@aamirpsy,

The redirection issue came from that particular option, so now you can work on your website by your needs, just make sure that the option is disabled and that's all.

I didn't see any other issue except that.

(@aamirpsy)
Joined: 4 months ago

Active Member
Posts: 9

@chris Thank you for helping me in the solution of my website. 

Now the same issue start with other website. But I check all setting as you mentioned. my website link https://studydesk.pk

BlackRaz
Admin
(@blackraz)
Joined: 7 years ago

Contributor
Posts: 161

@aamirpsy 

I suggest you to take a look this FAQ topic https://wpforo.com/community/faq/how-to-load-forum-on-home-page/

(@aamirpsy)
Joined: 4 months ago

Active Member
Posts: 9

@blackraz link not working. redirect to 404 page.

BlackRaz
Admin
(@blackraz)
Joined: 7 years ago

Contributor
Posts: 161

@aamirpsy try this one https://wpforo.com/docs/wpforo-v2/getting-started/forum-page/set-forum-on-home-page/

(@aamirpsy)
Joined: 4 months ago

Active Member
Posts: 9

Problem fixed. Thanks everyone

Posts: 8
(@davidsousa)
Active Member
Joined: 2 months ago

I couldn't fix it, I went back to previous versions as I saw above, I tried everything and
the site still redirects to the homepage.

1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 10154

@davidsousa,

Please open a separate topic and provide step by step information how have you set the forum page as a home page. If this is not the case, explain the issue again.