Notifications
Clear all

wpForo 1.x.x [Solved] Redirect problem

6 Posts
2 Users
0 Likes
1,084 Views
Miikinki
Posts: 30
Topic starter
(@miikinki)
Eminent Member
Joined: 2 years ago

I was messing something around with the menus and suddenly my wpforo forum's login and register button kinda stopped working how they worked before and how i want them to work. Now when i click the register button it just redirects to page which says "this page could not be found" and login button redirects to wordpress login page.

Β 

5 Replies
Miikinki
Posts: 30
Topic starter
(@miikinki)
Eminent Member
Joined: 2 years ago

Now i found out that when i type my website/admin to get to the wordpress frontpage to login and customize my site but instead of that it takes me to the forum loginpage. They are kinda like reverted now πŸ˜€

Reply
Miikinki
Posts: 30
Topic starter
(@miikinki)
Eminent Member
Joined: 2 years ago

UPDATE I did something (don't know what) but now the login is working normally inside forum. Register button still redirects to "website/%wpforo-register%" but it says "this page could not be found".

Now when the login works i got another problem and its when i want to log in to wordpress normally like i did before "website/admin" to customize my website it redirects me to the forum login.

Reply
Miikinki
Posts: 30
Topic starter
(@miikinki)
Eminent Member
Joined: 2 years ago

Sorry for doing a blog here, but now somehow everything is working now EXCEPT the one when i type "mywebsitename/admin" to get to wordpress and customize my site it redirects me to the forum login.

Reply
1 Reply
Alvina
Moderator
(@alvina)
Joined: 3 years ago

Member
Posts: 1872

Hi @miikinki,

Please navigate to the Dashboard > ForumsΒ  > Settings > Features admin page, find and make sure the following options are disabled:

. Replace Registration Page URL to Forum Registration Page URL - NO

. Replace Login Page URL to Forum Login Page URL - NO

More info here: https://wpforo.com/docs/root/wpforo-settings/features/#url-replace

Reply
Miikinki
Posts: 30
Topic starter
(@miikinki)
Eminent Member
Joined: 2 years ago

Thank you very much for help!!

Reply