Notifications
Clear all

wpForo 1.x.x Unable to use Contact Form 7

3 Posts
2 Users
0 Likes
563 Views
raja65
Posts: 3
Topic starter
(@raja65)
New Member
Joined: 2 years ago

HI,

 

Im getting a 404 page not found error when i add a CF7 shortcode in wordpress page. 

 

screenshots:

 

https://screenrec.com/share/iEKfX2MDCL

https://screenrec.com/share/DQg95iTS6M

 

 

2 Replies
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

Hi @raja65,

As far as I see you use the "Turn WordPress to wpForo" option in Forums > Settings > General Tab. Am I right? Please let me know why do you use this option? Do you know all disadvantages of this option? If you use this option, all your non-forum pages should be added in according textarea to be accessible. Please read the documentation attentive: https://wpforo.com/docs/root/getting-started/forum-page/turn-wordpress-to-wpforo/

So the contact page URL should also be added in "Exclude Page URLs" textarea.

I'd recommend use the regular way to set forum on home page rather than the "Turn WordPress to wpForo" option, this option turns off all non-forum content on your website frontend.

Reply
1 Reply
raja65
(@raja65)
Joined: 2 years ago

New Member
Posts: 3

@robert Thanks for the reply. yes i was using "turn wordpress to wpforo" option. 

i have tried your recommenced way of set forum on home page and created a new page "Home Forum" and added wpforo short code.  however it seems my current wordpress theme doesnt support it.  it looks odd:  https://screenrec.com/share/cig61o8S9q

Reply