Notifications
Clear all

wpForo 1.x.x [Closed] WordPress Admin Bar

11 Posts
5 Users
0 Reactions
2,221 Views
Posts: 16
(@airammontessori)
Eminent Member
Joined: 3 years ago

Well that's weird because everything was working fine before enabling this option which definitely overwrite some others WP settings.

I think you should change the coding of this setting from

Display admin bar for members. This option won't affect the admins.

to

Display admin bar for members only. This option won't affect the other roles: admin, editor, author, custom roles ... 

Currently it affects all other roles except "admin" indeed.

3 Replies
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@airammontessori,

Please clarify what you mean, I don't follow you.

(@airammontessori)
Joined: 3 years ago

Eminent Member
Posts: 16

@chris Well, this is the status of the admin bar PREVIOUS to installing WPForo:

I have custom roles defined by AAM (Advanced Access Manager). The bar was displaying fine for admin, editor, custom AAM roles inherited from editors, etc ...

I install WPForo. Now the admin bar has disappeared for every role except admin which is problematic. My editors need it. I changed the WPForo following setting: "Display admin bar for members. This option won't affect the admins." from disabled to enabled.

After enabling this setting the admin bar shows up for every connected user even basic member, something we don't want.

My recommendation is that you should change this option to:

"Display admin bar for members only. This option won't affect the other roles: admin, editor, author, custom roles ... " this way when it's disabled, it won't change the admin bar setting for editors, authors, custom roles, and so on ... or just removing this option completely as the admin bar display can be managed by other plugins anyway.

Currently I'm stuck! None of the plugins or even the function added to functions.php can overwrite this WPForo setting.

Not sure if I'm clearer ;).

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@airammontessori,

Go to your active theme folder(wp-content\themes\active theme), open functions.php file and add the below code at the end.

remove_action('show_admin_bar', 'wpforo_show_admin_bar' );
Page 2 / 2