Notifications
Clear all

wpForo 1.x.x [Solved] i have error indexing page_on_front forum page

9 Posts
3 Users
5 Likes
522 Views
tqarb
Posts: 45
Topic starter
(@tqarb)
Eminent Member
Joined: 1 year ago

I want to turn off Yoast SEO, does the code below suffice?

add_action( 'wp_head', function() {
 if( function_exists('is_wpforo_page') && is_wpforo_page() ){
 remove_all_filters( 'pre_get_document_title', 15 );
 }
Topic Tags
8 Replies
Martin
Posts: 868
Moderator
(@martin)
Support Team
Joined: 6 years ago

@tqarb,

It's being done by wpForo automatically, you don't need to add any code. There could be some Yoast meta tags but they don't conflict with wpForo SEO tags, wpForo SEO has already removed the Yoast tags form the forum page which could conflict.

7 Replies
tqarb
(@tqarb)
Joined: 1 year ago

Eminent Member
Posts: 45

@martin thank you for reply

So what is the cause of this problem? When I do a Google search for the forum by name it was showing me in the initial search results the forum page( page_on_front forum page )and below are columns of many internal links but now when I search the page ending with the community slug appears individually

Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 868

@tqarb,

It's not correct to check the result in Google, you should check it in your site, google may have an old version of indexing. What is the actual title? Where is the URL we can check it?

tqarb
(@tqarb)
Joined: 1 year ago

Eminent Member
Posts: 45

@martin this is URL

https://tqarb.com/

This change in search results happened yesterday

Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@tqarb,

The SEO titles work fine on your website, you have nothing to do there. Just wait for update. I don't see any issue. All your forums and topics titles are provided by wpForo and they are related to the corresponding forums and topics.

tqarb
(@tqarb)
Joined: 1 year ago

Eminent Member
Posts: 45

@robert okay I will wait . Thank you very much for your quick and wonderful support

Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 868

@tqarb,

Make sure you've submitted your forum sitemap to Google in Google Webmaster Tool.

Here is your forum sitemap: https://tqarb.com/community/sitemap.xml

If you want to disable indexing of user profiles, then go to Dashboard > Forums > Settings > Features tab and disable the "Enable User Profile Page indexing" option.

Also, there should be some tools to force some page re-indexing in the Google Webmaster Tools.

tqarb
(@tqarb)
Joined: 1 year ago

Eminent Member
Posts: 45

@martin The image below shows you what the forum looks like in Google when you search by the name of the forum

As you told me, wait and the problem will be solved automatically
It has been resolved
Thank you very much for your support 🌹