Notifications
Clear all

wpForo 1.x.x Registration from forum

7 Posts
2 Users
0 Likes
631 Views
starter
Posts: 4
Topic starter
(@starter)
New Member
Joined: 1 year ago

Hello!

I have the same problem, except that by doing the same operations, the problem remains.

A question, in the currently version of wpForo (mine is in french), I can't find the equivalent (in french) of= Forums > Settings > Features and then scrolling down to "Role-Usergroup Synchronization" and selecting "NO."

Has this menu changed places or is it called something else?

My application: last version of WP and last version of wpForo with media files extension

Thank you for your help

6 Replies
starter
Posts: 4
Topic starter
(@starter)
New Member
Joined: 1 year ago

I update: I found where this select button is and I also set it to "NO". However, nothing changes, it is still impossible to read the topics without connecting. The visitor can only see the forum and the topic titles but he cannot read them.

Reply
1 Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2391

Hi @starter,

Please give more details of your issue.

Reply
starter
Posts: 4
Topic starter
(@starter)
New Member
Joined: 1 year ago

Hello Chris, very thanks for your post. Here below an abstract of my problem.

I have installed wpForo for several months and it works perfectly. I added your extension to display media, that's good. I have the latest version of WP, wpForo and the theme is "Spa and Salon" and I have WooCommerce. PHP is the latest version available on my cPanel.

More than a month ago I discovered by chance, that visitors could not view the topics (so Google either). Since then I have made many attempts, without success.

Again this morning I copied the SQL code for the access of registrants and I pasted it in the visitors field. This in mySQL from the cPanel. But it was useless since, anyway, the visitor must be registered. I put back as before.

My need is the following: to allow anyone to see the forum topics, but not to register there. Only my customers (automatically added in wpForo) can have an account there to connect and interact.

This is my site with the wpForo: https://www.biolecher.be/community/

Thanks for your help/ comments !

Reply
3 Replies
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2391

@starter,

Go to Dashboard > Forums > Settings > Features Tab and Disable these options`

1. Enable User Registration

2. Replace Registration Page URL to Forum Registration Page URL

3. Replace Login Page URL to Forum Login Page URL

4. Replace Reset Password Page URL to Forum Reset Password Page URL

Also, you can remove Forums Login Menu from Dashboard > Appearance > Menus > wpForo Navigation Menu List.

 

 

Reply
starter
(@starter)
Joined: 1 year ago

New Member
Posts: 4

@chris Thank you very much,

Unless I'm mistaken, these features are well fixed (one was not). After that, I cleared the cache of wpForo but also that of the Firefox browser. Indeed, I have 2 pc one next to the other. The second, I use it to test reading as a visitor. With the browser cache cleared, and the display refreshed, unfortunately, wpForo continues to display: "You do not have permission to view the content. Register or Login" ...

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2391

@starter,

How I see you hadn't disable those options.

Reply