Notifications
Clear all

wpForo 1.x.x [Closed] Site/Forum slow

7 Posts
4 Users
0 Reactions
970 Views
Posts: 30
Topic starter
(@macaronisalad)
Eminent Member
Joined: 4 years ago

I'm on quality cloud hosting but the site/forum is still slow. They said that they are already allocating 32GB of Memory and 16 CPU cores just to make the website running but there are still some lags. At peak, we are only at 400 at most users at a time. 

They advised me to disable the "New Reply" and "New Topic" notification, It's not possible as per alvina here. I removed the template and it stops sending emails now. I think that fixed it but the lag still persists.

What I already did:

My database 10.3.22-MariaDB

Any advice? If you could take a look. I would really appreciate it. https://tradersloungeph.com/

Thanks!

 

 

 

 

6 Replies
Posts: 30
Topic starter
(@macaronisalad)
Eminent Member
Joined: 4 years ago

As per hosting, "slowness still happens, mostly related to the following admin-ajax.php calls. You'll need to look into optimising the wpforo installation and disable any stats or automatic refresh to see if it helps on reducing these calls."

2 Replies
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4478

@macaronisalad,

you should increase the value of the auto-drafting interval. The option is located in the Dashboard > Forums > Settings > Topics & Posts Tab. More info here: https://wpforo.com/community/wpforo-announcements/wpforo-1-6-3-is-released/#post-30787

Then we'd suggest you disable the user notification system. More info here: https://wpforo.com/community/wpforo-announcements/wpforo-1-7-0-is-released/

(@macaronisalad)
Joined: 4 years ago

Eminent Member
Posts: 30

Hi @sofy, Thanks for your reply. 

Did disable the auto drafting already. I guess it helps a little.

Okay, but there would be no way to notify the users of any notifications since I've kinda disable the new reply/new topic notification.

Any other recommendations?

 

 

 

 

Robert
Posts: 10526
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @macaronisalad,

This issue is not related to wpForo. First, please temporarily disable all cache plugins.

Second, navigate to Dashboard > Tools > Site Health admin page, take a screenshot and leave it here. Make sure you don't have WordPress loop back issue like this:

 

1 Reply
(@macaronisalad)
Joined: 4 years ago

Eminent Member
Posts: 30

Hi @robert, Thanks for your reply.

Have disabled and delete cache plugins.

I think I don't have that issue. Results are still loading on my end for quite a while now. I may need to resend the result. Please take a look.

--

It might be out of topic but I just want to ask this. let's say I have  500 concurrent users in a WPforo based forum at a time. How many resources(CPU/RAM) do you think I would need?

Is there a wpforo based forum that has high concurrent users? I would just like to take a look or maybe reach out to them so I can ask what hosting or what they did to eliminate lag. I think that would help our situation a lot.

Thanks!

Posts: 988
Moderator
(@martin)
Support Team
Joined: 8 years ago

Ok, Why you think the page is slow? Where we can see that slowness? Any direct link?

 

It might be out of topic but I just want to ask this. let's say I have  500 concurrent users in a WPforo based forum at a time. How many resources(CPU/RAM) do you think I would need?

This is not related to wpForo. You should ask this question to your hosting service.