Notifications
Clear all

wpForo 1.x.x [Solved] Slow when posting a new topic

16 Posts
5 Users
0 Likes
3,665 Views
Ansen
Posts: 23
Topic starter
(@ansen)
Eminent Member
Joined: 4 years ago

I created a new forum and a new post topic but it's still slow. Posting is still around 4 to 5 seconds. All wpForo cache options are enabled.

7 Replies
Anonymous20
(@anonymous20)
Joined: 7 years ago

Noble Member
Posts: 1602
Posted by: @ansen

I created a new forum and a new post topic but it's still slow. Posting is still around 4 to 5 seconds. All wpForo cache options are enabled.

Enable Wordpress DEBUG to a LOG, wait for a few hours (or just post some test topics) and check the DEBUG.LOG in wp-content.

Is it clear from errors?

Also what kind of hosting is that? Specs, PHP, mysql??

And this problem was always appearing, or new? You changed something or added something?

 

Ansen
(@ansen)
Joined: 4 years ago

Eminent Member
Posts: 23

@anonymous20

I have enabled the debug.log and I'm seeing the following errors:

[03-Mar-2020 18:18:10 UTC] PHP Notice: Undefined index: posts in /wp-content/plugins/wpforo/wpf-includes/functions-template.php on line 2167
[03-Mar-2020 18:18:10 UTC] PHP Notice: Undefined index: posts in /wp-content/plugins/wpforo/wpf-includes/functions-template.php on line 2167
[03-Mar-2020 18:18:10 UTC] PHP Notice: Undefined index: posts in /wp-content/plugins/wpforo/wpf-includes/functions-template.php on line 2167

The server is dedicated with 8 cores 32 GB Ram php 7.2 Mysql 5.6

It looks to have started with wpForo 1.6.4 and getts slower with each release.

 

Anonymous20
(@anonymous20)
Joined: 7 years ago

Noble Member
Posts: 1602

@ansen

Those are nothing to worry about.

So we are back to probably email sending issues.

Maybe wpForo team can help you more on this.

 

Ansen
(@ansen)
Joined: 4 years ago

Eminent Member
Posts: 23

@alvina

Hopefully, you can help me figure this slow posting problem.

 

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@ansen,

Please send the admin login details to info[at]gvectors.com email address. I'll ask the developers to check the issue for you.

 

Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

Thank you @ansen,

We're currently working on the dev website. However, for some reason it starts asking for htaccess username/password. it seems the directory is password protected, and we can't continue the debug.

BTW, we disabled some plugins and it works faster. Also, we found lots of Errors which come from other files and plugins. wpForo has error reported and all those errors are not wpForo errors. You can see those in Dashboard > Forums > Tools > Errors & Issues Tab.

 

Ansen
(@ansen)
Joined: 4 years ago

Eminent Member
Posts: 23

@robert yes the directory is password protected. I provided the credentials in the email I had sent.

 

 

 

Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

Hi @ansen,

We just finished the checking and found the main problem maker.

1. 90% comes from jReviews plugin. This plugin generates the most problemful error in WordPress. it stops WordPress loopback and keeps submitted processes loading until the 10001 ms timeout.

The loopback request to your site failed, this may prevent WP_Cron from ... 
Error encountered: (0)  Connection timed out after 10001 milliseconds.

This error can be found in WordPress website Health Checker ( Dashboard > Tools >  Health Checke).

This error affects all processes not only wpForo. Once we deactivated this plugin, the Health Checke stops reporting the problem. And the topic/post submitting becomes much faster.

 

2. The second is wpForo MyISAM tables. After the migration the tables with _wpforo_ prefix were not changed to InnoDB. but this is just a 10% speed affection, not more.

 

Page 2 / 2