Notifications
Clear all

wpForo 1.x.x [Solved] Autoptimize + wpforo

4 Posts
3 Users
1 Likes
2,272 Views
CENTRAL4ALL
Posts: 464
Topic starter
(@central4allgmail-com)
Honorable Member
Joined: 4 years ago

Which js files should be excluded from cache plugins like Autoptimize so it works properly?

I've excluded tinymce.min.js but attachments don't work

3 Replies
CENTRAL4ALL
Posts: 464
Topic starter
(@central4allgmail-com)
Honorable Member
Joined: 4 years ago

I excluded the assets folder, attachments still weren't working. I excluded the entire plugin folder and attachments weren't working. Finally it started working properly when I excluded the theme js folder. I assume because attachments and the theme use the same js file

Reply
1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

Hi CENTRAL4ALL,

Thank you for letting us know. Glad to hear that the issue is solved. 

Reply
Robert
Posts: 9265
Admin
(@robert)
Support Team
Joined: 6 years ago

Started from wpForo 1.5.4 when you install a brand new wpForo it detects Autoptimize and automatically adds this TiniMCE JS file in Autoptimize plugin exclude list.  In addition if somehow the JS is not added, you can find instruction and error report in Dashboard > Forums > Tools > Debug > Error & Issues:

Please navigate to Settings > Autoptimize > Main Tab, click on top right [Show advanced settings] button, find "Exclude scripts from Autoptimize" option, add this JS path ,wp-includes/js/tinymce, than click on [Save Changes and Empty Cache] button bellow.

Reply
Share: