Notifications
Clear all

wpForo Menu Shortcode issue

12 Posts
2 Users
0 Likes
138 Views
philfm
Posts: 11
Topic starter
(@philfm)
Active Member
Joined: 5 years ago

For me, referencing this documentation https://wpforo.com/docs/wpforo-v2/getting-started/wpforo-menu/, the following are not working for me in my Menus > wpForo Menu

  • Login: /%wpforo-login%/ and
  • Logout: /%wpforo-logout%/

I have cleared the wpForo cache, site cache, and everything else. Please advise.

Topic Tags
11 Replies
Chris
Posts: 1925
Admin
(@chris)
Support Team
Joined: 1 year ago

Hi @philfm,

Please provide your forum URL, and also make sure you have set the shortcode in the URL field. 

Reply
10 Replies
philfm
(@philfm)
Joined: 5 years ago

Active Member
Posts: 11

@chris https://www.quailvalleyfund.org/ (Login link in the top nav)

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1925

@philfm,

I have checked, and the login button is in its place, what is the problem?

Reply
philfm
(@philfm)
Joined: 5 years ago

Active Member
Posts: 11

@chris Thank you for your quick response. This is the problem.

  1. Visitors go to: https://www.quailvalleyfund.org/
  2. Visitors click the "Login" link at the top of the website
  3. Visitors are taken to this page (no login form) https://www.quailvalleyfund.org/community-forum/?foro=signin

In the past, the Login link took visitors to what you see when you visit https://www.quailvalleyfund.org/sign-in/?redirect_to=https%3A%2F%2Fwww.quailvalleyfund.org%2Fcommunity-forum

My expectation is that the "/%wpforo-login%/" code in the wpForo menu, results in the direct link to the login form ( https://www.quailvalleyfund.org/sign-in/?redirect_to=https%3A%2F%2Fwww.quailvalleyfund.org%2Fcommunity-forum).

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1925

@philfm,

there is no issue with using wpForo login shortcode to add wpForo login button on a different menu bar, checked on test website, I guess you have done something wrong. As your website login button URL is wrong.

Go to Dashboard Menus page, open the Login menu and provide a full screenshot of the Menu structure field.

 

Reply
philfm
(@philfm)
Joined: 5 years ago

Active Member
Posts: 11
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1925

@philfm,

Please provide admin access, I don't see that there is issue with wpForo login link, but somehow it doesn't work correctly.

Send the credentials to info[at]gvectors.com and let me know here that you have sent the email.

Reply
philfm
(@philfm)
Joined: 5 years ago

Active Member
Posts: 11

@chris Sent.

Thank you.

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1925

@philfm,

That login button is not created with wpForo menu shortcode and I couldn't even place a new Login button in that menu as I don't know how you have done it.

In the screenshot you show Login Button which is in wpForo Navigation Menu but not in your website top menu.

So you need to create a wpForo Login menu in the top menu using wpForo shortcode, however I have tried that as well and no result the Login button doesn't appear.

Reply
philfm
(@philfm)
Joined: 5 years ago

Active Member
Posts: 11

@chris I'm so sorry to have wasted your time Chris. Thank you for your help.

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1925

@philfm,

No need to be Sorry @philfm, As much as I’d love to help, your issue is beyond what we’re able to do.

Reply
Share: